How to Make Old HP Laserjet 1000 work with Ubuntu 16.04

EDIT: Sorry, I had one weird ‘-yes’ stuck in that first command a while back but have fixed it and this tutorial works again with copy/paste of commands.  Sorry for any inconvenience.

I’ll admit I should probably upgrade my printer but… it’s still alive so I won’t.  Problem is that now it’s getting harder to install on Ubuntu.  Hopefully this will help someone who is havin similar issues.  For me it looked like it was installed and working on 16.04 but it wouldn’t print so I reverted to command line because the HPLIP Toolbox seems to no longer be there in the Software Center…

1 Install the HP LIP Thing with GUI with this command in terminal

sudo apt-get install python-qt4 hplip-gui

2 Run the tool with this command:

hp-setup

3 Next, next, next, next, next, I agree, next….

4 Name your printer in ‘Description’5 Save, send test page (if you want), etc.

5 Save, send test page (if you want), etc.

Hope that helps!

 

Tags : , , , ,

23 thoughts on “How to Make Old HP Laserjet 1000 work with Ubuntu 16.04”

    1. After 12 Hours of tricking between windows 7 and Windows xp finally everythings works. I’ll call suddenly the person that has trash it with a new toner! Thank you

  1. Is it possible to setup Laserjet 1000 also if Ubuntu Mate is virtualized in Vitrualbox last version? Host Win7 home edition 64bit

    1. sadly I’m not sure nor do I have time to figure it out, however, I have done something like this before… but not with Mate

  2. Thank you very much! This works fine with Ubuntu 16.04.
    Today I updated to 18.04.1 and the printer does not work any more. I tried to do the steps 1-5 again, but Ubuntu says that ‘hp-setup’ was not found and that I should install with ‘hplip’. After starting the installation process, it says, that some packages could not be installed. hplip: refers to: libsane1 (>= 1.0.24) should not be installed.
    I watched in Synaptic, that libsane1 is 1.0.27 at the moment.

    Is there a way to solve the problem with Ubuntu 18.04.1?

    1. eeek! I haven’t tried on 18.04 yet. I just installed it last week! haha. Maybe let’s share our pain here for the benefit of others?

  3. Yeeesss ! After an ubuntu upgrade my Laserjet 1000 silenced down-with this advice it works again, even in 2018 ! Hope I can keep it rolling till I leave this world.

    Thanks !!

    1. awesome! i just upgraded to 18.04 so… i hope it works for me again too! :0 By the way, if you’re an Ubuntu fan have you checked out what the guys at https://ubports.com are doing to the mobile world? Pretty awesome…

      1. Hi,

        thanks for the link, very interesting. But since I’m
        using an Laserjet 1000 series printer on an 11 and 14 Year old hardware (Latitude D 530, Lifebook E8110) and furthermore still use WORD 2000 (WINE), I think I’ll leave the future to the younger generation…
        By the way, when I upgraded to ubuntu 18.04, I had to do some more steps than the given advice. I had to install some plug-in that the system required and then to take the electric cable from the printer-not to press just the on/off button, but remove the cable from the running printer and rewire it again, then it worked. This rewiring did indeed help in many cases, when it stumbled, or to simply restart the whole system.
        Thanks again !

        1. Too bad. The future will bite you if you don’t keep up 🙂
          Good news! I followed my own blog here and it worked. I didn’t have the step you are talking about but I did have a step that asked me to agree to go to a repository that was not confirmed by Ubuntu or something. That part was a bit weird, but i had to print quickly so I agreed. I wish I could remember what it was but anyway –

Leave a Reply

Your email address will not be published. Required fields are marked *