How to Use Echolink (QTEL) on Ubuntu 14.04

Thanks to Joe for actually searching the solution(s) and emailing me.  I figured we should publish this for others.  I figured worst case scenario, I would probably need to log these solutions for later when I forget, ha.

First of all, you can apparently use the native Echolink windows app using Wine in Ubuntu. But that’s kind of like praying while sitting on the toilet – it might work but it just feels wrong.  But I digress.

I will use this outdated tutorial designed for Ubuntu.   This is kind of like roasting your own coffee – it might be hard, and there might be a faster way to do it but nothing compares to that first sip if you sweat it out.  But I digress again…

Let’s put this Qtel thing onto our Fresh and Saucy Ubuntu 14.04 machines so we can ham with our homeboys in Nunavut.

Edit 140728 – It seems that Joe’s ports 5200 below did *not* help me but, everything was solved when I opened port range 5198-5199 UDP only in my router.  Instantly my Qtel sound was working on Ubuntu 14.04.  I hope this helps you all!  I’ll so another post exclusively on this issue.

Edit 140718

So, if you want the long and painful story of what I had to go through before I finally got Qtel (echolink) working on my Ubuntu 14.04 machine, please take all the time in the world and read through the story. It’s kind of funny if you like watching people suffer.  Otherwise, I’m just leaving it below to hopefully catch a bunch of SEO and save other people from the certain loss of hair and sanity as they try to figure it out.  The solution turned out to be very fast and easy, thanks to Joe (VA7OBI).  All of that will begin under the header “The Long Battle” below.

How to Get Qtel (Echolink) Running on your Ubuntu 14.04 machine

First, we  are not sure if you need this PPA added to your machine.  Both of us added it before doing this so let us know this tutorial works without adding it as we are both curious (sudo apt-add-repository ppa:ubuntu-hams-updates/ppa) .  If this tutorial doesn’t work for you, come back and add that repository.

1. Add the “Felix Repository”

In your terminal (control + alt + t) enter this verbatim and press enter: sudo apt-add-repository ppa:felix.lechner/hamradio

2. Open software center. Go to Software Sources

qtel-tut-soft-sources-01
Should see something like this list:
qtel-tut-source-list

Go through and find the ‘felix repository’ which will look something like this but the end will be different (maybe):

qtel-tut-felix-source

3.  Click ‘edit’ and a box will pop up like this.  Change ‘trusty’ to ‘raring’ in that field.  If you are still on ‘Raring Ringtail’ then you don’t even need this tutorial because it should work as is now. For those of us on 14.04 (Trusty Tahr) Just change it back to ‘raring’ like this image:

qtel-tut-felix-source-raring

Click ‘ok’ and then ‘save’ or whatever the option is.  Then, do the same thing for the ‘source code’ line as well. Do ‘edit’ and change the name to raring so you end up with it looking like this

qtel-tut-felix-final

4. Now, go back to your terminal and run these two commands one after the other:

sudo apt-get update

(this one puts felix in your list of software sources so you can actually download and install the Qtel app)

sudo apt-get install qtel

 (this one installs the qtel app)

That’s it!  It should work. Now you can just start typing ‘qtel’ in your HUD (or however you like to find your installed apps) and click it.  It should open and prompt for your ham radio license and password.

Note: In my case, it seems like it’s working just fine.  In the case of Joe, he had to open ports 5200 (UDP and TDP) in his router. If you don’t know how to open ports in your router, this website has been amazing for years.

We hope this has helped you and that you will look me up on Echolink and send me a note. I think it supports voice and chat.

 

The Long Battle

Below are the details of the things I tried before finding the quick and easy solution.  I never got to the final solution because the above solution happened right before, ha.

Edit 140717 7:30am-8:30

I contacted VA7OBI on the ham (it’s cooler to fix ham issues on the ham) and we walked through this.  Joe in a moment of revelation decided to click the qtel .deb file and badda bing/boom it started installing with the software centre.  It gave a warning of bad quality but I also got this method to start to work and it shows it as installed now.

Edit 140717 5am-7am – Current situation: FAIL! Do not do anything in this post yet if you aren’t pretty advanced because I mucked up my computer doing some of this, but please feel free to help me!

What I’m going to do is follow these steps provided by Charles Socci K1DNR verbatim and if they work, you’ll have screenshots and stories along the way.  If there are hiccups, hopefully I’ll find them and fix as we we go.  Let’s begin:

1 – Download packages from http://www.chrisronk.net/ham/qtel-debian.tar.gz or http://lz5pn.homeip.net/lz5pn/echoli…-debian.tar.gz.

Comment: second link didn’t work but it went to a kind of cool blog.  Use the first link.  What I’m going to do is save the file as download and then move it to my documents directory in one I just named QTEL.

2 – Extract

Comment:  I did a right click on the tar file and ‘extract here’

3 – Install getlibs – (http://ubuntuforums.org/showthread.php?t=474790)

Comment: What the heck is a ‘getlib’? Sounds like a domain for promoting the liberal party…but I digress..  And I will install…ok, so this link doesn’t work.  I knew this would happen so that’s why I’m making this post. Now I went back and read this post referred by Charles which turned out to be quite interesting.  Maybe don’t do anything yet until I find out it’s necessary but note that it expands on the original Charles Socci post and may solve issues I don’t here.

Dang… that took a while.  Finding getlibs was hard but I found it on this page somewhere in the middle.  Save yourself the time and just put these in your terminal one at a time and hope it works (seems to have worked for me without a hitch)(thanks Jeff Hendricks whoever you are…):

wget -c http://jeffhendricks.net/getlibs-all.deb

sudo dpkg -i getlibs-all.deb

4 – Type: sudo dpkg -i –force-all qtel_0.11.0-2_i386.deb (or whatever the name of your qtel .deb file is – we won’t be using the other deb files you extracted)

Comments: I’m going to first check the file name of that thing I extracted to see if it’s the same as this file name here…it indeed appears to be the same.  I’ll try just plopping this in the terminal to see what happens…error. No directory.  I figured.  So I obviously have to direct my terminal to this first.  I will type:

cd /home

cd /usernameofcomputer

cd Documents

cd QTEL

cd qtel-debian

now I will try it again: sudo dpkg -i –force-all qtel_0.11.0-2_i386.deb

It did something…maybe…it worked? Next!

5 – Type: getlibs /usr/bin/qtel

Comments: Not looking good. Here is what I got:

No match for libecholib.so.0.13
No match for libasyncqt.so.0.16
No match for libasyncaudio.so.0.16
libqt-mt.so.3: libqt3-mt
No match for libmng.so.1
libjpeg.so.62: libjpeg62
libsigc-1.2.so.5: libsigc++-1.2-5c2
No match for libasynccore.so.0.16
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libqt3-mt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libqt3-mt’ has no installation candidate

But what I noticed is that at least some of these ‘no match’ folks are in the qtel directory debian file I just downloaded above…. Weird? I’ll just try to open the software and see what happens:

Fail. It did not open by clicking app icon, nor did it open by entering ‘qtel’ in terminal. By doing the latter, though, it showed it to be missing the echolib file…

–> libecholib.so.0.13: cannot open shared object file: No such file or directory

Back to this dude’s blog to try that install order…

Install in this order:

1 getlibs-all.deb
2 echolib_0.13.0-2_i386.deb
3 libasync_0.16.0-2_i386.deb
4 libsigc++1.2-5_1.2.7-2_i386.deb
5 qtel_0.11.0-2_i386.deb

I’m trying this in my terminal in the qtel directory:

1. (already done above)

2. sudo dpkg -i –force-all echolib_0.13.0-2_i386.deb (seemed to do something but I am out of order from this dude’s blog since qtel is already installed…)

3. sudo dpkg -i –force-all libasync_0.16.0-2_i386.deb (seemed to work, though forced)

4. sudo dpkg -i –force-all libsigc++1.2-5_1.2.7-2_i386.deb

5. (already done above)

Now I’ll try step 5 again:

5 – Type: getlibs /usr/bin/qtel

Not looking good again:

libqt-mt.so.3: libqt3-mt
No match for libmng.so.1
libjpeg.so.62: libjpeg62
libqt-mt.so.3: libqt3-mt
No match for libmng.so.1
libjpeg.so.62: libjpeg62
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libqt3-mt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libqt3-mt’ has no installation candidate
E: Package ‘libqt3-mt’ has no installation candidate

I’ll just try entering qtel in terminal again and see what happens this time…

FAIL:

libqt-mt.so.3: cannot open shared object file: No such file or directory

I’m going to try now to remove qtel since it was out of order in my install.

sudo apt-get remove qtel

Now I’m going to install it again by going to that package directory with debian files and typing this again:

sudo dpkg -i –force-all qtel_0.11.0-2_i386.deb

It ‘seems’ better:

dpkg: error processing archive –force-all (–install):
cannot access archive: No such file or directory
Selecting previously unselected package qtel.
(Reading database … 272460 files and directories currently installed.)
Preparing to unpack qtel_0.11.0-2_i386.deb …
Unpacking qtel (0.11.0-2) …
Setting up qtel (0.11.0-2) …
Processing triggers for gnome-menus (3.10.1-0ubuntu2) …
Processing triggers for desktop-file-utils (0.22-1ubuntu1) …
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for mime-support (3.54ubuntu1) …
Errors were encountered while processing:
–force-all

Try again qtel in my terminal:

FAIL! same error: libqt-mt.so.3: cannot open shared object file: No such file or directory

what’s this libqt thing? I want to kill you slowly and painfully!

Try clicking icon app through super key:

FAIL! Nothing.

I’m going to sudo-apt-get-remove-kill-and-destroy all of them now and do them one at a time again…

1. sudo apt-get remove getlibs

2. sudo apt-get remove echolib

3. sudo apt-get remove libasync

4. sudo apt-get remove libsigc++

5. sudo apt-get remove qtel

Man. Doesn’t seem to want to uninstall qtel. I might have goofed by not listing the full package names above.  Maybe I messed up my computer and should have followed verbatim these package names when doing the sudo apt-get removes….

I will try install again…

1.

wget -c http://jeffhendricks.net/getlibs-all.deb

sudo dpkg -i getlibs-all.deb

2. sudo dpkg -i –force-all echolib_0.13.0-2_i386.deb

3. sudo dpkg -i –force-all libasync_0.16.0-2_i386.deb

4. sudo dpkg -i –force-all libsigc++1.2-5_1.2.7-2_i386.deb

5. sudo dpkg -i –force-all qtel_0.11.0-2_i386.deb

ERROR!

libqt-mt.so.3

how to get you!

This nasty thread probably has some answers. I will do it for the team 🙁

and by the way I screwed up my software centre at some point so it’s messed. May need full new OS.

Time for a break.  I’m calling Joe!

 

 

Tags : , , , , , , , , , , , ,

13 thoughts on “How to Use Echolink (QTEL) on Ubuntu 14.04”

  1. Qtel/Echolink works on some nodes, but not others. I changed server list to match the properly working Windows 7 OS. Still some links don’t work. I click connect and it times out, while some connect almost immediately.
    Using Ubuntu 14.04.1/Windows 7 with 64 bit Aspire5349 laptop.

    1. Great work building ubuntu for hams. I think a fundamental issue here is that someone would actually waste their time building ham stuff on crappy and dangerous windows os. Some people are so out to lunch that they think windows is an acceptable operating system, even for ham radio. I left a club meeting once because they were using windows. I thought ‘if these people claim to care about freedom, emergency preparedness and having some of their own control then they are fully out to lunch.” I’m glad that you don’t use windows. I was thinking we should start a more serious ham/ubuntu community for sure.

  2. Hello,

    I want to thank you for this neat tutorial. I’ve been looking for ways to use Echolink on Ubuntu, and none suited me so far.

    I went through your short tutorial and, for the first time, I had something going on in my box. I’m still waiting for my call sign to be issued but, at least, I have the initial configuration screen asking for my call sign and password.

    Since I don’t have an official call sign yet, I didn’t go any further than that. But I’m optimistic and hope it will work just out of the box.

    By the way, I didn’t install the ppa:ubuntu-hams-updates/ppa yet. As soon as I can fully test QTel’s functionality I’ll let you know how it went out.

    Thanks again for your tuto. It’s amazing how people in open source are willing to share their experiences just in a will to help others. I’ve been using Ubunto for many years now and I’m also involved in many other open source communities and projects but it never ceases to amaze me.

    Best Regards.

    1. No problem! This is just the tip of the iceberg. There are a million cool things that can and should be done with Ubuntu/radio. I’m around and I’ll fire you an email off the records (I don’t publish people’s stuff unless I don’t like them) and as you get into it let’s do some stuff! Hopefully more of us will get into the idea of creating a fully off-the-grid mesh network – perhaps not on ham frequencies but using the same skills and tech…

    2. Hello!
      As a n update to my first comment, I’ve been using QTel in Xubuntu 14.04 with no modification since I installed it the first time. My call was issued in june-2017 and, since then, I’ve made many contacts with it.
      Thanks again for this tutorial!
      Now trying different ways to connect my rig to it, so I can operate it remotely 🙂

  3. Just used your page to (again) install Qtel. Thanks. Had a major ‘puter blow-out over the holiday weekend (US — July 4) and am still recovering. Added the PPA and apt-get was ready. Installed the app and good-to-go. Thanks. Benton.

  4. Thank You so Much. Got this working on 1604 Xenial. Thanks for your tutorial. Step one as described. Step 2 I had to search for software center and run it. The apt are already updated to xenial so skip renaming. The rest as is. Search for Qtel and run it. Set it up and start talking.

    1. not a problem. glad it helped. be sure to read out my other articles on faith in Christ in this blog. I think you’ll find some of them interesting 🙂

  5. It works great…..tested on Lubuntu 14.04 and very old laptop 1 giga ram.
    thanks for the tutor really nice and very clear.
    Best regards— Ciao

  6. No sound. Install in artful aardvark [ubuntu 17.10 gnome 3.26.2] no problem as it was in the repository. Unfortunately no sound, rx or tx, any help?

    1. Got it working just fine now all I need do is find a good use for echolink. Sure do miss on-the-air. Maybe again some day, heck getting older but the alternative is not that great either KC9FOA…

Leave a Reply

Your email address will not be published. Required fields are marked *