How to Make Old HP Laserjet 1000 work with Ubuntu 16.04

EDIT: Sorry, I had one weird ‘-yes’ stuck in that first command a while back but have fixed it and this tutorial works again with copy/paste of commands.  Sorry for any inconvenience.

I’ll admit I should probably upgrade my printer but… it’s still alive so I won’t.  Problem is that now it’s getting harder to install on Ubuntu.  Hopefully this will help someone who is havin similar issues.  For me it looked like it was installed and working on 16.04 but it wouldn’t print so I reverted to command line because the HPLIP Toolbox seems to no longer be there in the Software Center…

1 Install the HP LIP Thing with GUI with this command in terminal

sudo apt-get install python-qt4 hplip-gui

2 Run the tool with this command:

hp-setup

3 Next, next, next, next, next, I agree, next….

4 Name your printer in ‘Description’5 Save, send test page (if you want), etc.

5 Save, send test page (if you want), etc.

Hope that helps!

 

Tags : , , , ,

4 thoughts on “How to Make Old HP Laserjet 1000 work with Ubuntu 16.04”

Leave a Reply

Your email address will not be published. Required fields are marked *